О программе

Программа Универсальный редактор годовых планов координации для управления светофорными объектами предназначена для программирования устройств управления дорожным движением производства ООО "Комсигнал" .

Программа позволяет:

  • В удобном графическом виде создавать, сохранять и в дальнейшем редактировать годовой план координации светофорного объекта
  • Создавать файлы прошивок для дальнейшего программирования микросхем флэш-памяти аппаратных устройств с использованием внешнего программатора

    • Программа нетребовательна к системным ресурсам и может работать в операционных системах Windows 2000 и выше


Работа с программой

Главное окно программы

Начнем рассмотрение работы с программой с описания пользовательского интерфейса .

Сразу после запуска программы открывается ее главное окно:

В верхней часте этого окна находится заголовок. В заголовке указывается путь к открытому файлу проекта или же (если открыт новый, еще несохранявшийся проект) надпись "Новый проект"

Ниже заголовка находится панель инструментов. Здесь собраны кнопки, вызывающие все основные функции программы.Если функция недоступна, то изображение на кнопке выводится в серых оттенках. При наведении на кнопку указателя "мыши" через небольшое время появляется всплываюшая подсказка с кратким описанием того, для чего эта кнопка предназначена. Одновременно в нижней части окна, на панели подсказок появляется строка с более подробным описанием функции. Все функции панели инструментов доступны также из контекстного меню, которое появляется при щелчке правой кнопки "мыши" в любом месте окна:

Ниже панели инструментов находится блок переключаемых редакторов. Именно здесь производитятся основные действия пользователя по созданию и редактированию элементов годового плана светофорного объекта. Переключение между редакторами производится щелчком "мышью" на ярлычке нужной панели редактора

В самой нижней части окна находится панель подсказок. На ней выводятся строки с описанием функций кнопок панели инструментов


Панель инструментов

Панель инструментов находится в верхней части главного окна программы

На ней расположены несколько групп кнопок.

Первая группа предназначена для выполнения действий над всем проектом

Создание нового проекта (того же можно добиться, нажав Ctrl+N)

Вызывается диалоговое окно открытия существующего проекта (Ctrl+O), при нажатии на правую часть кнопки со стрелкой выодится список последних 5 ранее редактировавшихся проектов

Сохранение текущего проекта (Ctrl+S). Если проект ранее уже сохранялся, то будут сохранены изменения в тот же файл, для нового проекта будет вызвано диалоговое окно сохранения. Проекты сохраняются в файлы с расширением .ypp

Вызывается диалоговое окно сохранения проекта в новый файл

Формирование файла прошивки из открытого проекта. Прошивки сохраняются в файлы с расширением .yp1

Вторая группа содержит 2 подгруппы кнопок, которые выполняют различные функции в зависимости от того, какой редактор открыт.

Первая подгруппа содержит 3 кнопки, предназначенные для манипулирования основными элементами открытого редактора, а вторая - 2 кнопки для манипулирования вложенными элементами основных элементов редактора

Режим редактирования рабочих циклов светофорного объекта:

Создается и помещается в список новый "пустой" цикл

Создается и помещается в список циклов копия редактируемого раб. цикла. Копию можно создать и непосредственно перетаскивая узел цикла"мышью" с нажатой улавишей Ctrl в таблице редактора раб. циклов

Редактируемый цикл удаляется из списка доступных (если цикл используется хотя бы раз в каком-либо суточном плане, то удаление невозможно)

Выводится список доступных рабочих фаз (Ф1...Ф12):

Выбранная фаза включается в редактируемый цикл

Редактируемая в редакторе циклов фаза удаляется из раб. цикла

Режим редактирования суточных планов светофорного объекта:

Создается и помещается в список новый "пустой" суточный план

Создается и помещается в список копия редактируемого суточного плана. Копию можно создать и непосредственно перетаскивая узел цикла"мышью" с нажатой улавишей Ctrl в таблице редактора суточных планов

Редактируемый суточный план удаляется из списка (если суточный план используется хотя бы раз в каком-либо недельном плане, то удаление невозможно)

Выводится список доступных циклов (в него включаются ранее определенные пользователем циклы, а также предопределенные стандартные состояния ОС, ЖМ и ЛУ):

Выбранный пользователем цикл включается вновую запись редактируемого суточного плана

Редактируемая в редакторе суточных планов запись удаляется из суточного плана

Режим редактирования недельных планов светофорного объекта:

Создается и помещается в список доступных новый "пустой" недельный план. Копию можно создать и непосредственно перетаскивая узел цикла"мышью" с нажатой улавишей Ctrl в таблице редактора недельных планов

Создается и помещается в список копия редактируемого недельного плана

Редактируемый недельный план удаляется из списка доступных (если недельный план используется хотя бы раз в годовом плане, то удаление невозможно)

Выводится список доступных суточных планов:

Выбранный пользователем суточный план помещается в редактируемую запись недельного плана

Редактируемая запись недельного плана очищается

Режим редактирования годового плана светофорного объекта:

Для светофорного объекта используется единственный годовой план, поэтому кнопки первой подгруппы в этом режиме не используются

Кнопки второй подгруппы манипулируют элементами годового плана:

Выводится список ранее определенных суточных планов:

Выбранный недельный план помещается во вновь созданную запись годового плана

Редактируемая запись удаляется из годового плана

Далее расположена кнопка вызова справочной системы [image] (файл справки также может быть быстро вызван нажатием клавиши F1)

И, наконец, последняя кнопка [image] вызывает завершение программы. Если пользователь занимался редактированием и не сохранил изменения, то будет выдан запрос на сохранение изменений


Редактор рабочих циклов

Редактирование рабочих циклов

В редакторе рабочих циклов назначаются рабочие циклы для светофорного объекта, которые в дальнейшем будут использоваться в суточных планах

Рабочий цикл в нашей терминологии предствляет из себя последовательность рабочих фаз из диапазона Ф1...Ф12 (не более 255 фазовых переходов в цикле) или предопределенное стандартное состояние (ОС, ЖМ или ЛУ). Фазы в цикле характеризуются длительностью, смещением начала первой по прядку фазы от начала цикла и порядком следования

Для объекта должен быть определен хотя бы один рабочий цикл

Циклы стандартных состояний предопределены и в таблице редактора циклов не показываются.

Новые циклы добавляются в список командой "Создать новый рабочий цикл"

Можно создавать и копии уже созданных циклов с помощью команды "Создать копию выделенного рабочего цикла" [image], предварительно выделив нужный узел цикла

По умолчанию новому циклу присваивается наименование "Цикл N", где N - номер в порядке создания цикла. Для удобства наименование цикла можно изменить, для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Цикл/фаза" напротив редактируемого узла цикла и ввести новое наименование:

Для задания смещения начала первой по порядку фазы цикла необходимо щелкнуть левой кнопкой "мыши" в столбце "Смещ./Длит." напротив редактируемого узла цикла и в появившемся редакторе ввести необходимое смещение (из диапазона 0...255 С)

Первоначально новый цикл "пустой", т.е. в нем не определен состав рабочих фаз и порядок их следования

Для добавления фазы в цикл используется команда "Включить в выделенный цикл фазу из списка"

Фаза вставляется в конец цикла, если в таблице выделен узел цикла, или в следующую позицию за позицией выделенного в цикле узла фазы

Порядок фаз можно изменить перетаскиванием узла фазы "мышью" в пределах цикла на нужную позицию

Можно изменить и номер фазы. Для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Цикл/фаза" напротив редактируемого узла фазы и выбрать нужную фазу из появившегося списка

По умолчанию длительность новой фазы 1 с. Чтобы изменить ее, необходимо щелкнуть левой кнопкой "мыши" в столбце "Смещ./Длит." напротив редактируемого узла фазы и в появившемся редакторе ввести необходимое значение (суммарная длительность цикла не может превышать 255 с!)

Фаза удаляется из цикла командой "Удалить фазу из выделенного рабочего цикла"

Цикл полностью удаляется командой "Удалить выделенный рабочий цикл" [image]. Циклы, используемые в каком-либо суточном плане помечаются значком [image] в столбце "#" , такие циклы удалить невозможно


Редактор суточных планов

Редактирование суточных планов

В редакторе суточных планов назначаются суточные планы работы светофорного объекта, которые в дальнейшем могут использоваться в недельных планах

Суточный план представляет из себя хронологический список записей, определяющих времена начала действия рабочих циклов и стандартных состояний на светофорном объекте

Для объекта должен быть определен хотя бы один суточный план

Новые планы добавляются в список командой "Создать новый суточный план "

Можно создавать и копии уже созданных планов с помощью команды "Создать копию выделенного суточного плана " [image], предварительно выделив нужный узел в таблице

По умолчанию новому плану присваивается наименование "Суточный план N", где N - номер в порядке создания суточного плана. Для удобства наименование плана можно изменить, для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Суточный план/ Цикл" напротив редактируемого узла плана и ввести новое наименование:

Первоначально новый суточный план "пустой", т.е. в нем не определено ни одной записи

Для добавления записи в план используется команда "Включить в выделенный суточный план новую запись"

Запись вставляется в конец плана, если в таблице выделен узел плана, или в следующую позицию за позицией выделенного в плане узла записи

Время начала действия записи можно отредактировать. Для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Время" напротив редактируемого узла записи плана и в появившемся редакторе ввести необходимое значение часов и минут (должно быть уникально в пределах суточного плана!)

Можно изменить и цикл в записи. Для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Суточный план/ Цикл" напротив редактируемого узла записи и выбрать нужный цикл (или стандартное состояние) из появившегося списка

Запись удаляется из суточного плана командой "Удалитьвыделенную запись из суточного плана "

План полностью удаляется командой "Удалить выделенный суточный план " [image]. Суточные планы, используемые в каком-либо недельном плане помечаются значком [image] в столбце "#" , такие суточные планы удалить невозможно


Редактор недельных планов

Редактирование недельных планов

Этот редактор позволяет конфигурировать недельные планы работы светофорного объекта.

Недельный план состоит из записей, определяющих порядок выполнения суточных планов по дням недели.

Для светофорного объекта должен быть определен хотя бы один недельный план

Новые планы добавляются в список командой "Создать новый недельный план "

Можно создавать и копии уже созданных планов с помощью команды "Создать копию выделенного недельного плана " [image], предварительно выделив нужный узел в таблице

По умолчанию новому плану присваивается наименование "Недельный план N", где N - номер в порядке создания недельного плана. Для удобства наименование плана можно изменить, для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "План/ день недели " напротив редактируемого узла плана и ввести новое наименование:

Первоначально новый недельный план "пустой", т.е. в нем не определено ни одной записи

Для того, чтобы установить значения суточного плана, который должен выполняться в данный день недели, необходимо щелкнуть левой кнопкой "мыши" в столбце "Суточный план " и выбрать необходимый план из появившегося списка:

План полностью удаляется командой "Удалить выделенный недельный план " [image]. Недельные планы, используемые в годовом плане помечаются значком [image] в столбце "#" , такие недельные планы удалить невозможно


Редактор недельных планов

Редактирование годового плана

Этот редактор позволяет конфигурировать годовой план работы светофорного объекта.

Годовой план состоит из записей, определяющих хронологический порядок выполнения недельных планов.

Для светофорного объекта должна быть определена хотя бы одна запись годового плана

Первоначально годовой план нового проекта "пустой", т.е. в нем не определено ни одной записи

Для добавления записи в план используется команда "Включить в годовой план новую запись"

Запись вставляется в начало плана, если в годовом плане нет ни одной записи, или в следующую позицию за позицией выделенного вплане узла записи

Дату начала действия записи можно отредактировать. Для этого необходимо щелкнуть левой кнопкой "мыши" в столбце "Дата" напротив редактируемого узла записи плана и в появившемся редакторе ввести необходимое значение

Для того, чтобы установить значения недельного плана, который должен выполняться в данный день и месяц, необходимо щелкнуть левой кнопкой "мыши" в столбце "Недельный план " и выбрать необходимый план из появившегося списка:

Записи удаляются командой "Удалить выделенную запись годового плана"


Техническая поддержка

При возникновении проблем с ипользованием программы обращайтесь в службу техподдержки ООО "Комсигнал"

mailto:support@comsignal.ru

или непосредственно к разработчику:

Ведущий программист Юдин Владимир Геннадьевич

Последние версии программы можно найти на нашем сайте: http://comsignal.ru