О программе

Программа Конфигуратор дорожных контроллеров КДУ предназначена для программирования дорожных контроллеров КДУ, а так же для создания и ведения паспортов светофорных объектов, управляемых контроллерами КДУ.

Программа позволяет:

  • Конфигурировать контроллеры, непосредственно подключая их к персональному компьютеру через последовательный асинхронный интерфейс RS-232 (COM-порт)

  • Создавать файлы прошивок для дальнейшего программирования микросхем флэш-памяти контроллеров с использованием внешнего программатора

  • Создавать паспорта светофорных объектов с указанием графической схемы движения транспортных средств по фазам и направлениям. Паспорта создаются в формате HTML Help (CHM) и могут быть в дальнейшем распечатаны на принтере. Для удобства пользователей вместе с программой поставляются шаблоны наиболее типичных планов перекрестков

  • Результаты работы можно сохранять в файлах проектов для дальнейшего редактирования

    • Поддерживаются следующие возможности контроллеров КДУ:

  • Конфигурирование для работы с ламповыми или светодиодными светофорами

  • Каскадирование контроллеров

  • Назначение сигналов светофоров силовым выходам контроллеров

  • Установка контроля перегорания "красных" синальных ламп

  • Установка контроля отключения "зеленых" сигнальных ламп

  • Установка маски контроля мощности сигнальных ламп

  • Опеределение направлений движения транспортных средств и установка времен разгрузки в промтактах

  • Определение рабочих циклов переключения фаз движения и установка минимальных и рабочих длительностей. Количество и порядок фаз во всех рабочих циклах одинаковы. Также поддерживается использование предопределенных дежурных циклов ОС (отключенное состояние) и ЖМ (желтое мигание)

  • Работа с одним устройством ТВП или аналогичным и определение порядка переключений в цикле ТВП

  • Определение нескольких суточных планов работы светофорного объекта. В каждом суточном плане можно установить какое время и в каких циклах будет работать светофорный объект

  • Определение одного недельного плана работы светофорного объекта

  • Для удобства рабочим циклам и суточным планам могут быть присвоены осмысленные наименования

    • Также для светофорного объекта может быть создана графическая схема движения транспортных средств по фазам и направлениям


Системные требования

Программа предназначена для работы на персональном компьютере в операционных системах MS Windows 98SE, Windows NT4 SP6A, Windows ME и Windows 2000. В крайнем случае возможна работа в Windows 95OSR2 с установленным обновлением HTML Help

Для правильной работы с паспортами светофорных объектов необходим MS Internet Explorer 5.5 или выше

Для комфортной работы рекомендуется установить разрешение экрана не менее 800*600 и цветовое разрешение не хуже High Color (16 бит)

Для возможности распечатки сформированных паспортов светофорных объектов необходим принтер, лучше с возможностью печати в цвете

Для непосредственного конфигурирования контроллеров КДУ необходимо наличие COM-порта


Установка программы

Дистрибутив программы поставляется либо на компакт-диске, либо в виде самораспаковывающегося архива.

Если Вы устанавливаете программу с компакт-диска, то просто скопируйте полностью папку KDU-3 на жесткий диск компьютера.

В случае установки из самораспаковывающегося архива распакуйте файлы программы на жесткий диск компьютера.

Далее рекомендуется создать на рабочем столе ярлык для быстрого запуска файла KDU-3.exe

После этого программа полностью готова к работе


Работа с программой

Рассмотрим работу с программой на примере создания нового проекта.

Сразу после запуска программы открывается ее главное окно:

В верхней часте этого окна находится панель инструментов.

Ниже находится панель переключения режимов редактирования. Нажатие на кнопку вызывает переключение программы в режим редактирования, указанный на кнопке.

Еще ниже находится редактор, в котором непосредственно и происходит работа


Панель инструментов

Панель инструментов находится в верхней части главного окна программы

На ней расположены несколько групп кнопок.

Первая группа предназначена для выполнения действий над всем проектом

Создание нового проекта (того же можно добиться, нажав Ctrl+N)

Открытие существующего проекта (Ctrl+O)

Сохранение текущего проекта (Ctrl+S)

Сохранение копии текущего проекта

Запись прошивки непосредственно во флэш-память контроллера либо в файл

Формирование паспорта светофорного объекта

Вторая группа содержит всего 2 кнопки [image], которые вызывают в разных режимах работы программы разные действия

Кнопка [image] открывает графический редактор схемы движения по светофорному объекту

Далее расположена кнопка [image], вызывающая настоящую справку

И, наконец, последняя кнопка [image] вызывает завершение программы


Создание нового проекта

Для создания нового проекта нажмите кнопку [image] на панели инструментов главного окна программы (того же можно добиться, нажав комбинацию Ctrl+N)

В появившемся меню выберите из списка тип контроллера. Для отказа от создания нового проекта просто щелкните "мышью" в свободном поле главного окна. Если до этого Вы редактировали другой проект и внесли в него изменения, то Вам будет предложено сохранить предыдущий проект


Открытие существующего проекта

Для открытия существующего проекта нажмите кнопку [image] на панели инструментов главного окна программы или комбинацию Ctrl+O

В появившемся меню выберите необходимый проект из списка (если работали с ним недавно) или в стандартном диалоге укажите местонахождение проекта


Сохранение текущего проекта

Для сохранения текущего проекта нажмите кнопку [image] на панели инструментов главного окна программы или комбинацию клавиш Ctrl+S

Если открыт ранее созданный проект, то он будет сохранен. Если сохраняется вновь созданный проект, то будет предложено выбрать его наименование и местоположение в стандартном диалоговом окне


Сохранение копии проекта

Для сохранения копии проекта нажмите кнопку [image] на панели инструментов главного окна программы

В появившемся стандартном диалоговом окне укажите наименование проекта и его местонахождение


Создание прошивки микросхемы флэш-памяти

Для того, чтобы записать созданную конфигурацию непосредственно в микросхему флэш-памяти контроллера или сохранить в файл для дальнейшего использования с внешним программатором, нажмите кнопку [image] на панели инструментов главного окна программы.

Если необходимо сохранить прошивку в файл, то выберите в появившемся меню пункт "Сохранить в файл...", укажите в появившемся стандартном диалоговом окне наименование и местонахождение файла. Прошивка будет сохранена в файлы с расширением .k?, где вместо знака вопроса будет указан номер контроллера в каскаде

Для непосредственной записи с использованием внутреннего программатора контроллера выберите из списка номер каскада и далее следуйте инструкциям


Работа с внутренним программатором контроллера

Для программирования контроллеров КДУ-3 необходимо иметь следующее оборудование:

  • персональный компьютер с установленной операционной системой Windows (см. Ситемные требования)
  • кабель-соединитель компьютера с контроллером, поставляемый предприятием изготовителем контроллеров с первой партией
  • по дополнительной заявке поставляется стенд программирования контроллера, обеспечивающий более удобное подключение контроллера к компьютеру и просмотр записанной программы на светодиодном индикаторе в реальном режиме после ввода программы
    • Сохранилась возможность производить программирование контроллера с помощью ранее поставленного программатора для контроллеров КДУ-1М, записывая сформированный файл непосредственно в память микропроцессора

    Порядок программирования контроллера встроенным программатором следующий:

  • при выключенном питании компьютера подсоедините кабель-соединитель компьютера с контроллером к свободному разъему COM-порта на задней стенке корпуса компьютера, а другой конец подключить к разъему пульта диагностики на панели клеммной контроллера
  • вставьте микросхему флэш-памяти в соответствующий сокет на печатной плате электронного блока контроллера, установите джампер (перемычку) XP1 и установите электронный блок в клеммную панель контроллера;
  • включите питание компьютера и дождитесь загрузки операционной системы Windows и запустите программу KDU-3;
  • следуя приведенным инструкциям, создайте необходимую конфигурацию работы светофорного объекта;
  • подайте напряжение питания на клеммы "220 В" и "0" клеммной панели контроллера и включите автомат питания контроллера;
  • запишите созданный файл в память контроллера согласно приведенной ниже инструкции;
  • снимите питание с клеммной панели контроллера, выньте блок электронный и удалите джампер XP1.
  • установите контроллер на стенд и проверьте правильность введенной программы.

    • Запись программы в контроллер

    После проведения подготовки к записи программы в контроллер, описанной выше, и включения питания контроллера, необходимо перевести его в режим желтого мигания тумблером на панели (тумблер вверх). Контроллер готов к программированию. Если Вы уверены, что программная конфигурация сформирована правильно, то можно производить запись во флэш-память контроллера. Просто нажмите кнопку с изображением микросхемы [image], в появившемся меню выберите пункт меню, совпадающий с номером каскада и типом программируемого контроллера, после чего появится окно программатора

    Номер COM-порта на экране должен совпадать с номером порта, к которому подключен кабель. Затем нажмите кнопку "Программировать". При невозможности программирования в нижней части окна будет выведено сообщение об ошибке, иначе начнется процесс записи, ход которого будет показываться индикатором выполнения. Процесс программирования в любой момент можно прервать нажатием кнопки "Остановить". После программирования для выхода нажмите кнопку "Выйти".

    По окончании программирования удалите джампер XP1. После записи настоятельно рекомендуется протестировать работу контроллера на стенде.

    Запись в файл для последующей работы с внешним программатором

    Если по каким-то причинам необходимо воспользоваться внешним программатором, то сохраните работу в файл. Для этого необходимо нажать кнопку с изображением микросхемы [image]. В появившемся меню выберите пункт Сохранить в файл..., после этого в появившемся стандартном диалоговом окне введите название файла и укажите путь сохранения. Для каждого контроллера будет создан файл с расширением .KN, где N - номер каскада (K0 для первого контроллера, K1 - для второго и т.д.). Обратите внимание, что этои файлы потом не могут быть загружены в программу KDU3 - это не файлы проекта.


Формирование паспорта светофорного объекта

Для формирования паспорта светофорного объекта нажмите кнопку [image] на панели инструментов главного окна программы.

После выбора в появившемся стандартном диалоговом окне наименования и местоположения файла будет сформирован паспорт светофорного объекта (файл с расширением .chm) в стандартном формате HTML Help и открыт для просмотра. Далее этот файл можно просматривать и распечатывать встроенными средствами Windows на любом компьютере.

Учтите, что ранние версии Windows не поддерживают работу с этим форматом в полной мере (см. Системные требования). В случае возникновения проблем попробуйте установить с дистрибутивного компакт-диска обновленную версию MS Internet Explorer 6.0 (находится в папке MSIE6.dis) и обновление HTML Help (файл hhupd.exe в папке MS HTML Help)


Панель переключения режимов редактирования

Находится под панелью инструментов главного окна программы и служит для переключения режимов редактирования. При нажатии на кнопки становятся активными следующие редакторы:

Редактор свойств используемых контроллеров

Редактор свойств транспортных направлений

Редактор свойств фаз движения

Редактор рабочих циклов

Редактор суточных планов

Редактор недельных планов

Кнопка активного редактора подсвечивается


Редактор свойств контроллеров

В этом редакторе устанавливаются общие свойства проекта, а также осуществляется каскадирование контроллеров для совместной работы и устанавливается тип используемой сигнальной аппаратуры

В поле Светофорный объект необходимо указать наименование светофорного объекта

В поле Системный идентификатор устанавливается идентификатор для работы в системе АСУДД

Ниже находится таблица, в которой указываются свойства используемых контроллеров. Для того, чтобы каскадно подключить новый контроллер, необходимо нажать на кнопку [image] и в появившемся меню выбрать тип подключаемого контроллера. Контроллер будет добавлен в конец таблицы. Нажатие кнопки [image] в свою очередь удаляет из таблицы выделенный в ней контроллер (кнопка недоступна, если не выделен ни один контроллер или используется единственный контроллер, или выходы выделенного контроллера используютс каким-либо направлением)

Для того, чтобы изменить вид используемой сигнальной аппаратуры, необходимо щелкнуть левой кнопкой "мыши" в ячейке Тип ламп

В столбце Направления для каждого выхода контроллера указано подключенное к нему направление, а в столбце Сигнал - тип сигнала (красный, желтый, зеленый) подключенного направления


Редактор свойств транспортных направлений

В этом редакторе устанавливаются свойства транспортных направлений светофорного объекта. Вся работа производится в таблице редактора

Для того, чтобы создать новое направление, необходимо нажать кнопку [image] на панели управления (эта кнопка доступна, если задействованы не все выходы используемых контроллеров). В появившемся меню необходимо выбрать необходимый тип направления. Направление будет добавлено в конец таблицы. Сигналы направления будут сопоставлены наиболее подходящим свободным выходам используемых контроллеров.

Нажатие кнопки [image] вызывает удаление из таблицы выделенного направления.

Сказанное выше не относится к использованию ТВП - этот вид направления добавляется и удаляется при включении/отключении поддержки ТВП в редакторе фаз движения

В заголовках столбцов используются следующие условные обозначения для различных типов сигналов:

Красный сигнал

Желтый сигнал и сигнал Ждите ТВП

Зеленый сигнал и сигнал Идите ТВП

сигналы Т-образного светофора для управления общественным транспортом

Если назначение выходов по умолчанию по каким-то причинам не подходит, то возможно переназначить и даже совсем не задействовать любые сигналы направления. Для этого необходимо выделить ячейку необходимого сигнала левой кнопкой "мыши" и в появившемся меню выбрать необходимый выход или [Нет], если сигнал не будет использоваться

Так же можно включить/отключить контроль красных сигналов на перегорание ламп в столбце [image] и контроль зеленых ламп на отключение в столбце [image] щелчком левой кнопки "мыши" в соответствующей ячейке для тех выходов контроллеров, для которых эта возможность поддерживается аппаратно

Для каждого направления необходимо установить времена разгрузки в промтактах

В следующих столбцах усанавливаются времена разгрузки при переходе из разрещенного состояния взапрешенное:

указывается, за сколько секунд до конца промтакта будет установлено зеленое мигание

- желтый сигнал

- ранний красный

В следующих столбцах усанавливаются времена разгрузки при переходе из запрещенного состояния в разрешенное:

- за сколько секунд до конца промтакта включится красный с желтым

- ранний зеленый

Естественно, что указанные установки возможны только для тех видов направлений, для которых они предусмотрены


Редактор свойств фаз движения

В редакторе устанавливаются фазы движения, используемые в рабочих циклах светофорного объекта, а также возможность работы с устройством ТВП

Вся работа отображается в таблице

Чтобы вставить в цикл новую фазу, необходимо нажать кнопку [image] . После выделенной фазы будет вставлена ее копия, которую можно отредактировать. Кнопка недоступна, если ни одна фаза не выделена или если уже установлено максимально возможное количество фаз (10). Для работы в системе АСУД не рекомендуется использовать более 8 фаз.

Чтобы удалить выделенную фазу необходимо нажать кнопку [image]. Кнопка недоступна, если нет выделенных фаз или определена единственная фаза

Поддержка ТВП включается/отключается нажатием соответствующей кнопки, при этом в список направлений автоматически добавляется/удаляется направление ТВП, и в таблице показывается/исчезает отображение фаз цикла ТВП

Кроме того возможно отображение промтактов в свернутом/развернутом виде

Таблица имеет следующую структуру:

В строке Цикл показывается разделение на рабочий цикл и цикл ТВП

В строке Такт отображаются номера тактов цикла (для ТВП показываются со знаком *, при выполнении цикла ТВП переход на цикл будет осуществлен после такта рабочего цикла с номером, предшествующим номеру первого такта цикла ТВП)

В строке Время показывается время начала такта относительно начала цикла

В строке Фазы показывается разделение на фазы и промтакты (в режиме показа промтактов в "свернутом" виде все промтакты между фазами показываются как один такт). Для фаз указывается их номер в цикле

В строке Tmin указывается вычисленная на основании времен разгрузки направлений длительность промтактов и минимальная длительность фаз. Минимальная длительность фаз может редактироваться в диапазоне от 1 с до минимальной длительности фазы в определенных рабочих циклах.

Для каждой фазы можно указать щелчком левой кнопки "мыши" разрешенные в ней направления, при этом длительность промтактов будет автоматически пересчитана

Условные обозначения:

- движение по направлению разрешено (зеленый)

- зеленый мигающий

- желтый

- движение по направлению запрещено (красный)

- красный с желтым


Редактор рабочих циклов

В редакторе рабочих циклов назначаются рабочие циклы для светофорного объекта, которые в дальнейшем будут использоваться в суточных планах

При создании нового проекта для него не определен ни один рабочий цикл

Чтобы создать новый рабочий цикл, необходимо нажать кнопку [image] , новый рабочий цикл будет добавлен в конец таблицы.

Для удаления рабочего цикла необходимо выделить его в таблице и нажать кнопку [image]. Невозможно удалить цикл, который используется в каком-нибудь суточном плане (такие циклы помечены значком [image]).

Рекомендуется для удобства работы присваивать вновь созданным рабочим циклам осмысленные наименования. Для этого воспользуйтесь полем ввода, которое становится доступным при выделении ячейки с наименованием цикла.

Назначение строк таблицы:

В строке Цикл отображается деление на рабочую часть цикла и часть, отрабатываемую при вызове ТВП

В строке Такт отображаются номера тактов цикла (для ТВП показываются со знаком *, при выполнении цикла ТВП переход на цикл будет осуществлен после такта рабочего цикла с номером, предшествующим номеру первого такта цикла ТВП)

В строке Время показывается время начала такта относительно начала цикла

В строке Фазы показывается разделение на фазы и промтакты (все промтакты между фазами показываются как один такт). Для фаз указывается их номер в цикле

В строке Tmin указывается вычисленная на основании времен разгрузки направлений длительность промтактов и минимальная длительность фаз. Минимальная длительность фаз может редактироваться в диапазоне от 1 с до минимальной длительности фазы в определенных рабочих циклах.

Далее построчно следует список определенных для светофорного объекта рабочих циклов. Для каждой фазы в рабочем цикле можно установить длительность в диапазоне от Tmin до 255 с


Редактор суточных планов

В редакторе суточных планов назначаются суточные планы работы светофорного объекта, которые в дальнейшем могут использоваться в недельном плане

При создании нового проекта всегда создается суточный план по умолчанию, в котором светофорный объект постоянно находится в дежурном цикле ОС

Для того, чтобы создать новый суточный план, необходимо выделить суточный план по умолчанию и нажать кнопку [image]. Выделенный план можно удалить с помощью кнопки [image]. Невозможно удалить суточные планы, которые используются в недельном плане (они помечены значком [image]), а также если определен единственный суточный план. Для этого воспользуйтесь полем ввода, которое становится доступным при выделении ячейки с наименованием суточного плана.

Рекомендуется присвоить вновь созданному плану осмысленное наименование.

Суточный план состоит из записей, определяющих время перехода и рабочий или дежурный цикл (ОС, ЖМ), который должен начать действовать. В плане обязательно должна быть хотя бы одна запись. Записи доступны для редактирования, если развернуть строку соответствующего суточного плана (щелкните по значку [image] в первом столбце строки плана) и затем выделить нужное поле записи.

Что бы добавить новую запись, выделите запись, после которой необходимо произвести вставку и нажмите кнопку [image]. Имейте в виду, что невозможно вставить запись в случаях, если разница по времени между выделенной записью и следующей за ней 1 минута или время выделенной записи равно 23:59.

Аналогично можно удалить выделенную запись (если она не единственная в плане) с помощью кнопки


Редактор недельных планов

Этот редактор позволяет конфигурировать недельный план работы светофорного объекта.

При создании нового проекта всегда создается недельный план по умолчанию, в котором светофорный объект постоянно находится в дежурном цикле ОС

Недельный план состоит из записей, определяющих день недели перехода и суточный план, который должен начать действовать. В плане обязательно должна быть хотя бы одна запись. Записи доступны для редактирования, если развернуть строку недельного плана (щелкните по значку [image] в первом столбце строки плана) и затем выделить нужное поле записи и выберите значение из появившегося меню.

Что бы добавить новую запись, выделите запись, после которой необходимо произвести вставку и нажмите кнопку [image]. Имейте в виду, что невозможно вставить запись после последней записи, если день начала ее действия воскресенье.

Аналогично можно удалить выделенную запись (если она не единственная в плане) с помощью кнопки


Графический редактор схемы движения по светофорному объекту

Графический редактор схемы движения по светофорному объекту позволяет задать план перекрестка и тректории движения по транспортым направлениям. В дальнейшем эта информация используется при формировании паспорта светофорного объекта.

Окно редактора вызывается нажатием на кнопку [image] на панели инструментов главного окна программы

Открытое окно всегда находится на переднем плане и при необходимости может быть закрыта или частично свернута

Окно редактора состоит из следующих функциональных зон (слева направо):

  • Таблица транспортных направлений
  • Панель свойств объектов схемы
  • Панель схемы светофорного объекта
  • Инструментальная панель


Таблица транспортных направлений

Находится в левой части графического редактора схемы движения по светофорному объекту

Содержит список определенных ранее транспортных направлений. Каждое направление содержит вложенный список ярлычков и траекторий движения транспорта, а каждая траектория - список характерных точек траектории

Для того, чтобы открыть вложенный список, необходимо нажать на кнопку

Позволяет выделять транспортные направления, траектории движения и характерные точки траекторий, одновременно выделяются объекты на панели схемы перекрестка и обновляется панель свойств объектов схемы.

Можно перетаскивать "мышью" траектории из одного направления в другое


Панель свойств объектов схемы

Находится в графическом редакторе между панелью транспортных направлений и панелью схемы перекрестка.

В верхней части панели высвечивается номер выделенного транспортного направления

Ниже находятся редакторы свойств объектов схемы,

Для ярлычков с номерами направлений можно точно установить местоположение, для траекторий движения - координаты и размеры, для характерных точек траекторий - координаты и радиус дуги поворота


Панель схемы перекрестка

Находится в графическом редакторе схемы движения по светофорному объекту между панелью свойств объектов схемы и инструментальной панелью

На панель помещаются фоновое изображение плана перекрестка, траектории движения транспортных средств и ярлычки с номерами направлений

Можно добавлять на панель новые объекты, редактировать существующие и удалять ненужные (см. описание работы с инструментальной панелью и контекстным меню).

При перемещении курсора "мыши" над схемой, он меняет свою форму в зависимости от того, над каким объектом находится - (над траекториями и ярлычками - крестообразная стрелка, над маркерами перемещения - двунаправленная стрелка, над характерными точками траектории - перекрестие)

С помощью "мыши" можно выделять объекты на схеме, менять их размеры и перемещать в пределах панели (так же можно выделять объекты схемы и через таблицу направлений и менять их свойства с помощью редакторов на панели свойств)

Выделенная траектория помечается черными прямоугольниками маркеров, перемещая которые "мышью" можно менять размеры траектории.

Выделенная характерная точка высвечивается синим цветом. Ее можно также перемещать "мышью" (при этом траектория будет перерисовываться)


Характеристики траектории движения

Характеристики траектории движения (немного терии)

Для каждого транспортного направления можно показать на схеме перекрестка траектории движения транспорта и пешеходов. Для каждого направления можно указать необходимое количество таких траекторий. Графический редактор схемы движения позволяет показывать на схеме перекрестка даже очень сложные траектории. Траектории строятся из отрезков прямых и сопряженных с ними дуг окружности:

Каждая траектория задается характерными точками, а так же координатами описывающего прямоугольника. Каждая точка характеризуется координатами (X,Y) и радиусом поворота (R) траектории. Траектория задается как минимум 2-мя характерными точками. Для каждой траектории можно создать столько характерных точек, сколько необходимо

Изменение высоты (H) и ширины (W) масштабирует траекторию. Можно перемещать траекторию и полностью

Траектории движения транспорта показываются однонаправленными стрелками, пешеходов - двунаправленными


Информационные ярлычки

Редактор позволяет размещать на схеме перекрестка информационные ярлычки с номерами направлений. Ярлычки всегда помещаются на переднем плане. Можно изменить местоположение ярлычка, отбуксировав его "мышью" или с помощью редактора свойств


Контекстное меню схемы перекрестка

Если нажать на панели схемы перекрестка правой кнопкой "мыши", то появиться контекстное меню схемы. Оно позволяет выполнять различные действия над выделенным объектом схемы:

  • Вставить точку. Посредине между выделенной точкой и следующей за ней будет вставлена новая характерная точка. Это бывает необходимо при создании сложныч траекторий движения
  • Удалить точку. Будет удалена выделенная характерная точка
  • Реверс. Развернет выделенную тректорию в обратную сторону
  • Отразить вертикально, отразить горизонтально - траектория будет зеркально развернута относительно вертикальной/горизонтальной оси
  • На передний план, на задний план - поместит выделенную траекторию соответственно впереди/позади остальных траекторий выделенного направления
  • Удалить объект - выделенная траектория/ярлычок будут удалены
  • Вставить копию - рядом с выделенной траекторией будет вставлена ее копия


Инструментальная панель графического редактора схемы

С правой стороны окна графического редактора схемы светофорного объекта находится инструментальная панель

Кнопки инструментальной панели выполняют следующие действия:

Сворачивает/разворачивает окно редактора. Это бывает удобно, когда необходимо проверить правильность раскладки фаз движения по направлениям. Для этого, не закрывая окно графического редактора, необходимо перейти на страницу редактора фаз главного окна программы и поочередно выделять фазы
Вызывает стандартное окно выбора файла плана перекрестка для последующей загрузки
Удаляет план перекрестка
Вызывает меню выбора вида траектории движения
Удаляет выделенный объект схемы
Закрывает окно редактора


Меню выбора вида траектории

Появляется при нажатии кнопки [image] и позволяет выбрать одну из стандартных траекторий движения транспортных средств или ярлычок с номером направления. Выбранный вид траектории или ярлычок помещается в левый верхний угол панели схемы перекрестка и добавляется во вложенный список траекторий выделенного транспортного направления. После этого необходимо отбуксировать "мышью" новый объект на свое место на схеме перекрестка и отредактировать траекторию с помощью редакторов свойств


Где взять планы перекрестков?

В качестве фонового изображения можно использовать любую картинку размером 200px * 200px в любом из распространенных форматов .wmf, .emf, .gif, .jpg, .bmp

Такие изображения должны быть предварительно созданы с помощью любого доступного графического редактора (CorelDraw, Adobe Illustrator, CorelXara, MS Paint и др.)

Вместе с программой поставляются уже готовые планы наиболее рапространенных видов перекрестков, они находятся в папке Шаблоны перекрестков в директории программы

Там же находятся и файлы проектов для популярных редакторов CorelDraw (.cdr) и Adobe Illustrator (.ai). Вы можете взять их за основу для быстрого создания своих планов перекрестков

Готовый план загружается в панель схемы движения по светофорному объекту с помощью кнопки [image] на инструментальной панели или из контекстного меню панели и может быть в любое время заменен другим


Техническая поддержка

При возникновении проблем с ипользованием программы обращайтесь в ООО "Комсигнал"

тел. (3432) 697025

mailto:comsi@imail.ru

или непосредственно к разработчику:

Ведущий программист Юдин Владимир Геннадьевич

Последние версии программы можно найти на наших сайтах:

Сайт 1

Сайт 2