Система сбора информации и управления городским освещением

«ГОРСВЕТ».

Настоящее руководство нацелено на разъяснение непонятных моментов при работе с системой, но рассчитано на опытных пользователей. Это означает, что вы должны уметь работать с операционной системой Windows в минимальном объеме. Необходимо знать, что такое файловая система, каталоги, пути, уметь копировать и переименовывать файлы. При работе с Internet, вы должны уметь пользоваться электронной почтой и уметь находить необходимые страницы в сети. Поэтому, для повышения вашей пользовательской квалификации, читайте дополнительную литературу по операционным системам Windows, и постарайтесь не задавать разработчикам вопросы типа: «Как запустить программу?» или «Как выключить компьютер?» В описании указаны действия, которые вы должны выполнить для достижения той или иной цели, однако при первом упоминании эти действия описываются более подробно, а впоследствии в сокращенном виде. Считается, что достаточно один раз объяснить эту процедуру подробно, следующие описания этой процедуры избыточны.

Внимание. По всем интересующим вас вопросам, обращайтесь mailto: 2318@r66.ru.

1. О системе.

Система «ГОРСВЕТ» (далее просто «система») предназначена для управления городским освещением, для сбора информации о состоянии объектов, входящих в систему, и для контроля состояний объектов системы городского освещения. В состав системы входит оборудование (контроллеры сбора информации и управления КСИ, устройства включения и выключения освещения, устройства передачи данных: радио- и силовые модемы, системный концентратор, компьютер на месте диспетчера), каналы связи (радиоканал и канал передачи данных по силовой сети), программа диспетчера системы «Gorsvet». Схематично система выглядит следующим образом:

Контроллеры КСИ связываются друг с другом посредством линий силовой сети, либо с системным концентратором через радиомодемы посредством радиоканала, либо с системным концентратором напрямую (минуя радиоканал) по интерфейсу RS-485. Связь между контроллером КСИ и радиомодемом осуществляется также по интерфейсу RS-485. Связь между радиомодемами осуществляется через радиоканал. Связь между системным концентратором и компьютером осуществляется по интерфейсу RS-232. Для связи контроллеров по силовой сети в состав контроллера КСИ должна входить плата модема силовой сети МСС. Для связи только по радиоканалу, наличие этой платы необязательно.

2. Работа контроллера КСИ.

Контроллер КСИ может работать в двух режимах: автономно и централизованно. В автономном режиме контроллер может работать как в системе, так и независимо от других устройств. В этом случае контроллер может не иметь каналов связи с центром (радио- и силовые модемы), а настройка контроллера производится при помощи пульта диагностики, подключающимся обслуживающим персоналом к контроллеру непосредственно на объекте. При помощи пульта диагностики в контроллере выставляются значения времени, числа, месяца, года, корректора часов, значения счетчика электроэнергии. Эти значения нужны для правильной работы контроллера. В этом случае обслуживание контроллера сводится к периодической корректировке времени.

Автономная работа в системе позволяет централизованно корректировать время на объекте, а также контролировать параметры работы контроллера: получать значения напряжений и токов по каждой фазе в разных точках наблюдения, получать значения электросчетчика с учетом коэффициента трансформации трансформаторов тока, установленных на объекте, проверять состояние выходов контроллера на конфликты и т.д. Несмотря на все это, включения и выключения уличного освещения производятся контроллером самостоятельно по графику переключений, находящемуся в памяти контроллера.

Централизованная работа кроме этого позволяет совершать переключения по командам с пульта управления диспетчера. Централизованная работа может поддерживаться только при наличии связи с пультом управления по любому из доступных каналов связи. При отсутствии связи с пультом управления контроллер переходит в автономный режим работы.

Для правильной работы системы рекомендуется, чтобы контроллер находился в автономном режиме. Это означает, что в памяти контроллера должен находиться достоверный план переключений уличного освещения. Перевод контроллера в режим централизованной работы должен носить исключительный характер (например, при ремонте линий освещения или в дни неопределенного состояния освещения при переводе времени на летнее время и обратно). Изменение плана переключений на длительный срок должно сопровождаться изменением плана переключений в контроллере. Это поможет свести к минимуму ошибки работы системы, связанные с человеческим фактором а также возможными ошибками работы пульта управления диспетчера (зависание или отключение компьютера, неверная конфигурация системы, отсутствие связи и т.д.).

3. О времени и плане переключений.

Время в системе городского освещения имеет очень важный характер, поэтому на описании это параметра надо остановиться подробнее. Также следует отметить, что к тому, что описано в этом разделе следует отнестись очень внимательно и правильно понять, как определяется время в системе. Это позволит вам избежать ошибок в конфигурировании системы и контроллеров. Итак основной постулат связанный с временем контроллера: не существует перехода на летнее время и обратно!!! Это означает, что время в контроллерах всегда является зимним. Время компьютера считается исходя из времени года и может быть разным (если в вашей местности существует переход на летнее время), например, если ваш часовой пояс +5, то время в вашей местности зимой равняется абсолютному мировому времени, отсчитываемому от Гринвича плюс пять часов, а летом к этому времени добавляется еще, как правило, один час. В данном случае компьютер диспетчера переводится на летнее время, а все контроллеры КСИ продолжают работать по зимнему времени. Эта исключительная особенность позволяет избежать неуниверсальности перехода на летнее время и обратно. Таким образом, при составлении плана переключений следует учитывать факт отсутствия перехода на летнее время и обратно. На самом деле, этот факт даже облегчает создание плана переключений из-за того, что времена включения вечернего освещения и выключения утреннего освещения меняются плавно и не претерпевают скачков. Также это позволяет избежать неопределенности при переходах за счет того, что в разные года переходы происходят в разные числа месяца. Однако, если в вашем административном образовании (городе, селе и т.д.) существует экономный режим ночного освещения, то отсутствие летнего времени порождает трудности в определении начала и конца этого режима именно в моменты переходов.

Например:

В вашей местности происходят отключения уличного освещения с 1 до 6 часов ночью.

Тогда в плане переключений в зимнее время года должны фигурировать времена: 1.00 и 6.00 часов.

В летнее время эти времена (подчеркиваю, в плане переключений) будут 0.00 и 5.00 часов.

Но что делать в моменты переходов на летнее время и обратно?

Есть три варианта решения этой проблемы:

1. В последние семь дней марта и последние семь дней октября эти времена будут 1.00 и 5.00 часов.

2. Определяйте времена переходов каждый год и изменяйте ежегодно план переключений в контроллерах.

3. Ежегодно изменяйте план переключений и в моменты неопределенности (25-31 марта и 25-31 октября) переводите контроллеры в режим централизованного управления.

Выберите для себя подходящий вариант, хотя наиболее универсальным как для автономных контроллеров, так и для контроллеров в централизованном управлении является первый вариант.

Теперь перейдем к рассмотрению плана переключений и его определению. План переключений задается редактором плана переключений объекта, который может вызываться либо из программы на месте диспетчера «GORSVET» либо из программы конфигуратора контроллера «FlashEdit». В любом из этих случаев редактор плана переключений будет иметь примерно следующий вид:

Редактор выполнен в виде таблицы, состоящей из ячеек, соответствующих времени перехода в нужное состояние. Все ячейки редактируются следующим способом: левой кнопкой мыши выбирается нужная ячейка или группа ячеек, правой кнопкой мыши открывается меню, соответствующее данному типу ячейки. Например, для ячеек времени задается время переключения либо удаляется любое значение, а для ячеек состояния выходов (ячейки вверху таблицы) определяется название и состояния выходов. Также в редакторе можно создать новый план переключений, открыть существующий, сохранить измененный, а также добавить столбец или удалить выделенные столбцы посредством кнопок, расположенных вверху редактора. Файлы планов переключений имеют расширение *.swi.

4. Конфигуратор контроллера КСИ «FlashEdit».

Конфигуратор контроллера позволяет сконфигурировать контроллер КСИ для правильной работы системы и изменить план переключений. Результатом работы редактора КСИ является файл с расширением *.fl. Этот файл прошивается во флэш-память контроллера КСИ (отсюда и название: FlashEdit). Внешний вид программы конфигуратора показан на рисунке.

В строке «описание объекта» задается название объекта для удобства его идентификации. Глобальный адрес – это уникальный адрес объекта, который должен однозначно определять этот объект в системе (диапазон адресов: 1-65535). Локальный адрес – это уникальный адрес в локальной сети предка этого контроллера (предком может являться контроллер или маршрутизатор, расположенный выше в дереве конфигурации сети) с диапазоном адресов 1-254 (адрес 0 зарезервирован для самого предка, а адрес 255 для системных нужд). Маршрутизатор – это устройство, которое имеет адрес и может передавать пакеты данных из одной локальной сети в другую. Одним из маршрутизаторов является плата KN-485, расположенная в концентраторе системы. Схематично все описанное выше можно изобразить на примере:

Для объекта №32 предком является объект №17, предок которого – объект №537. Локальным адресом объекта №244 является число 4, а глобальным – 244. Объект №1 участвует в одной локальной сети (объекты 17 – 32 – 1 – 73 – 244), а объект №17 участвует в двух локальных сетях (17 – 32 – 1 – 73 – 244 и 537 – 320 – 17 – 3 –502), при этом в первой сети имеет локальный адрес – 0, а во второй – 2. Таким образом, строится все дерево конфигурации сети.

Параметр «Количество оборотов диска на кВт*ч» - это постоянная величина электросчетчика, который стоит рядом с контроллером в шкафу освещения. Вы должны знать, какой электросчетчик используется совместно с вашим контроллером.

Коррекция часов – это параметр, означающий, сколько микросекунд производится сброс процессора контроллера умноженных на два. Этот параметр позволяет корректировать ход часов контроллера для точного измерения времени. Это актуально для контроллеров, работающих не в системе. Для контроллеров, работающих в системе этот параметр не так важен из-за того, что компьютер на месте диспетчера корректирует ход часов контроллеров в системе. Для правильной работы системы контролируйте правильность хода времени на месте диспетчера, а также проверяйте правильность установления даты. Иначе, система будет работать неправильно.

В строке «Файл плана годовых переключений» задается файл, который будет использоваться при создании файла прошивки контроллера. Это файл с расширением *.swi, содержащий в себе план переключений освещения на год, будет отрабатываться контроллером в процессе эксплуатации. Вы можете отредактировать этот файл, применив двойное нажатие мыши на этой строке либо при помощи нажатия кнопки вверху окна программы конфигуратора. Если эта строка пуста, то выбрать файл вы можете посредством нажатия кнопки справа от пустой строки.

Таблица «Порядок каналов» предназначена для конфигурации каналов связи, с которыми работает контроллер. Существует три физических канала связи, по которым контроллер может обмениваться информацией с центром (пультом управления системы) (0 канал – канал 485 интерфейса для связи по радиоканалу или по выделенному проводу, 1 и 2 канал – каналы связи по силовым проводам (два направления)). Хочу подчеркнуть, что каналом связи с центром является тот физический канал, по которому будут идти данные в центр. Данные могут проходить через другие контроллеры или маршрутизаторы, но направление вы можете определить безошибочно. В большинстве случаев контроллер работает только с одним каналом связи с центром, два других канала являются альтернативными для случаев пропадания связи по первому каналу. Таким образом, нас интересует только первая строка данной таблицы. Первому логическому каналу мы ставим в соответствие нужный физический канал (пишем в первую строку «0», если это радиоканал, и, как правило, «1», если это силовой модем). Если контроллер имеет несколько каналов связи с центром (именно с центром, не с контроллерами-потомками!!!), то определяются второй и третий логический канал. Эти логические каналы называются «каналами возврата», потому что они определяют физические каналы, по которым будут возвращаться ответы на запросы центра.

Таблица «Множители» содержит калибровочные коэффициенты для измерения напряжений и токов контроллером в разных точках шкафа освещения. Эти коэффициенты предназначены для более точного определения этих параметров. Определение этих параметров называется калибровкой. Калибровка параметров может происходить как с пульта диагностики, так и при работе в системе, но в условиях лаборатории.

5. Программная оболочка системы «GORSVET».

В состав системы городского освещения входит программная оболочка «GORSVET». Это компьютерная программа, работающая под управлением операционной системы WindowsNT4, Windows 2000, WindowsXP. Хотя программа может работать под управлением операционной системы Windows 9х, для большей устойчивости и производительности рекомендуются операционные системы, сделанные на основе NT-технологии. Программа Gorsvet предназначена для вывода на экран монитора состояния системы, управления системой и для архивирования данных, связанных с эксплуатацией системы. Диспетчер, работающий с пультом управления системы, общается с системой городского освещения именно посредством программной оболочки Gorsvet.

На рабочем поле программы, как правило, располагается карта населенного пункта, который обслуживается системой. На карте в виде прямоугольников изображены объекты, относящиеся непосредственно к контроллерам установленным в системе. В нижнем левом углу программы располагается индикатор связи с концентратором, который подключается к компьютеру через один из com-портов. Этот индикатор показывает работу приемника и передатчика, а также наличие команд в очереди запросов. В нижнем правом углу располагается информация о текущей дате и времени. В заголовке программы указывается информация о системе и пользователе, который в данный момент является диспетчером. Ниже заголовка располагаются кнопки меню программы, позволяющие делать настройки программы, менять действующего пользователя, просматривать отчеты о работе системы, получить информацию о системе и ее авторах.

Управление контроллером КСИ. Как уже было сказано, контроллеры на карте изображаются в виде прямоугольников. Однако, разные типы контроллеров могут иметь разный вид. Управление объектом мы рассмотрим на примере контроллера КСИ. В большинстве случаев контроллер изображен в виде полупрозрачного квадрата, в котором указан глобальный номер контроллера, а также цветными квадратами меньшего размера отображено состояние контроллера в данный момент. Приблизительный вид объекта показан на рисунке.

В верхней половине квадрата обозначен глобальный номер контроллера. В данном случае, это №1. Левый нижний угол отведен для индикации состояния объекта. Возможные состояния цвета для состояния объекта: белый (состояние объекта неизвестно), зеленый (контроллер работает нормально), красный (в работе контроллера есть ошибка или неверное состояние объекта). Красное состояние также сопровождается миганием, причем, верхняя половина квадрата тоже мигает красным. Правый нижний угол отведен для индикации состояния освещения. Возможные состояния цвета: черный (освещение отключено), желтый (освещение включено).

Также возможно состояние, изображенное на следующем рисунке, когда прозрачность квадрата повышена. Это состояние показывает, что система не интересуется судьбой объекта, т.е. не производит опрос параметров данного контроллера. Такой режим называется «независимое управление».

Одновременно с тем, что описанный квадрат показывает состояние объекта, он является активной областью для управления объектом и просмотра его свойств. Вы можете нажать на квадрат левой кнопкой мыши, тогда квадрат трансформируется в прямоугольник большего размера, содержимое которого отображает основные свойства объекта. (см. рис.) В данном случае к основным визуальным элементам объекта добавляются дополнительные параметры, состояние которых отображено в виде строк и небольших квадратиков, отображающих состояние этого параметра. Это - название объекта «Тестовый объект», время и дата в контроллере на объекте, уровень ошибок контроллера «Ошибок нет», текущее управление контроллера на объекте «Автономное управление» (напомню, что у контроллера КСИ возможны два состояния: Автономное управление и Централизованное управление), состояния выходов управления (три): «Выход 1 включен»…, означающих что все три выхода управления освещением переведены во включенное состояние, замеры напряжений на выходах (три) по каждой фазе: «Выход. Фаза А: 0.00 В»… Квадратики у нижних трех параметров имеют красный цвет, что означает, значение этих параметров неверно или конфликтует с чем-либо. Действительно, все три выхода включения освещения переведены во включенное состояние, а на проводах освещения по каждой фазе замерено нулевое напряжение (ноль вольт). Конфликт или ошибка хотя бы по одному параметру вызывает индикацию общей ошибки объекта (красный квадрат под номером объекта «1»).

Также, вы можете нажать на квадрат, обозначающий объект в системе правой кнопкой мыши. При этом появится окно, позволяющее управлять контроллером КСИ. (см. рис.) В этом окне изображена мнемосхема объекта (шкафа освещения), на которой условно изображены компоненты шкафа. Вы можете увидеть замеры напряжений и токов по трем фазам в разных точках шкафа, увидеть состояние автомата или предохранителей, состояние выходных устройств включения освещения, увидеть потребляемую в данный момент мощность и значение электросчетчика, время, уровень ошибок и состояние управления контроллера.

Кроме того, окно управления объектом содержит панель управления объектом (ради чего и нужно это окно), называемую «Управление» (см. рис.). Эта панель позволяет диспетчеру управлять данным объектом с пульта управления. Вы можете нажать на кнопку с треугольником возле строки, в которой в данный момент написано: «автономное», при этом строка развернется в меню, в котором указаны все доступные режимы управления объектом. Таких режимов четыре: автономное управление (объект работает по плану переключений, находящемуся в памяти контроллера КСИ на объекте, за объектом производится наблюдение), координированное управление (объект работает по плану переключений, находящемуся в памяти компьютера на месте диспетчера и определенному для данного объекта, за объектом производится наблюдение), диспетчерское управление (объект выполняет команды диспетчера, который может в данный момент времени изменять состояние объекта, за объектом производится наблюдение), независимое управление (наблюдение за объектом не производится, его опрос не ведется). В автономном режиме управления объектом контроллер КСИ на объекте переходит в автономное состояние, при координированном и диспетчерском управлении переходит в централизованный режим управления, а при переходе в независимый режим управления не меняет своего состояния. Следует отметить, что централизованный режим управления контроллера КСИ достигается постоянным вниманием со стороны центра (постоянно должен вестись опрос объекта), при отсутствии связи более 10 минут, контроллер переходит в автономный режим работы. Помните, что когда переводите объект в независимое управление после работы в централизованном управлении контроллера, через 10 минут контроллер перейдет из централизованного режима работы в автономный. То же самое произойдет при нарушении связи или отключении компьютера, поэтому раньше оговаривалось, что основным режимом работы объекта должен являться автономный режим управления. Он позволит избежать сбоев системы по причине отсутствия связи по тем или иным причинам.

Подробнее хотелось бы остановиться на диспетчерском управлении объектом. В этом режиме управления диспетчер может управлять состоянием выходных устройств включения освещения, таких как реле, контакторы и пр. Мнемосхема объекта создавалась для шкафов освещения, в которых установлены реле, включающие освещение независимо по каждой фазе, однако в реальной ситуации, в шкафу может стоять один или два контактора, которые управляют сразу несколькими фазами одновременно. Об этом следует помнить и корректировать свои действия при работе с такими объектами. Итак, диспетчеру доступны регуляторы интенсивности освещения по каждой фазе, в данном случае (см. рис.), включено освещение по фазе В на 100 процентов. Плавная регулировка создана для устройств, способных плавно изменять светимость ламп в системе городского освещения, однако отклонение регулятора от положения нуля на любое значение (25%, 50%, 75% и 100%) приводит к включению реле в данной фазе. Следует отметить, что диспетчерское управление объектом следует производить только в крайних случаях (при ремонте сети или экстренном отключении объекта), следует избегать повседневного включения или отключения уличного освещения посредством работы в диспетчерском режиме управления. Пользуйтесь автономным режимом управления!

6. Просмотр отчетов в программе «GORSVET».

Как уже было сказано, программа «Gorsvet» позволяет контролировать и сохранять в базе данных параметры работы системы. Впоследствии вы можете посмотреть, что находится в базе данных системы. Для этого в программной оболочке «Gorsvet» выберите меню «отчет». Запустится построитель отчетов, с помощью которого вы можете построить запрос на выборку данных из базы данных системы по определенным критериям.

Для начала, вам надо выбрать, по каким объектам системы вы хотите просмотреть отчет. В левой части экрана вы можете выбрать те объекты, которые хотите проконтролировать. По умолчанию, выделены все объекты. Объекты, по которым пройдет выборка, обозначены знаком «птичка». Вы можете убрать или поставить «птичку» правой кнопкой мыши.

Далее определите интервал времени, который вас интересует. В правой верхней части экрана вы найдете надписи «Выбрать с:» и «по:», поля рядом с которыми определяют интервал времени. Изначально установлен интервал времени с 0 часов 00 минут по 23 часа 59 минут сегодняшнего числа.

После того, как вы определили интервал времени, жмите кнопку с треугольником, направленным вправо, находящуюся перед надписью «Сорт. по». Через какое-то время вы увидите все интересующие вас события. Вы можете рассортировать события по категориям, для чего выберите нужную категорию сортировки в меню «Сорт. по».

7. Настройка системы.

Внимание! Настройка системы является самым важным и сложным пунктом работы с системой, поэтому внимательно отнеситесь к тому, что изложено в этой главе.

Следует отметить, что вы, как пользователь программы «GORSVET», должны обладать правами на настройку системы, если вы такими правами не обладаете, программа не позволит вам производить настройку. Это сделано для того, чтобы обезопасить работу системы от несанкционированных действий неквалифицированных пользователей.

Итак, самое простое: перемещение объектов по карте осуществляется при помощи левой кнопки мыши с одновременно нажатой кнопкой «Ctrl» на клавиатуре.

Посложнее: для того, чтобы создать пользователя и наделить его правами вам необходимо сделать следующие действия: в главном меню программы «GORSVET» выберите пункт меню «Настройки >> Пользователи >> Добавить пользователя», при этом выскочит окно добавления пользователя, в котором вы должны указать имя нового пользователя и нажать кнопку «добавить». Далее, либо закрываете это окно кнопкой «закрыть», либо добавляете еще одного пользователя, изменив имя. После добавления всех необходимых пользователей давите кнопку «закрыть». Следует отметить, что при добавлении пользователей создаются пользователи с «пустым» паролем и не обладающие никакими правами. Если при загрузке программы вы выберете этого пользователя, то даже не увидите объектов на карте. После этого закрывайте программу «GORSVET» и запускайте ее снова. Теперь новым пользователям необходимо назначить пароли и права.

Для того, чтобы изменить права пользователя необходимо сделать следующее. В меню выберите пункты «Настройки >> Пользователи >> Свойства пользователя», при этом возникнет окно «Пользовательские настройки», а поверх него окно выбора пользователя, в котором вы должны указать свое имя и пароль. Указывайте свое имя и пароль и перейдете в окно пользовательских настроек. Во строке «пользователь» выберите необходимого вам пользователя. Отмечайте те пункты прав пользователя, которыми вы хотите наделить нового пользователя. Нажав кнопку «сменить пароль», вы можете указать новый пароль для данного пользователя. Давите кнопку «сохранить», а затем (после изменения свойств всех необходимых вам пользователей) «выйти». Изменения вступят в силу немедленно.

Для того, чтобы удалить пользователя необходимо сделать следующее. В меню выберите «Настройки >> Пользователи >> Удалить пользователя», при этом возникнет окно удаления пользователя, в котором вы можете удалить ненужных вам пользователей.

Для того, чтобы изменить свой пароль, выберите «Настройки >> Пользователи >> Сменить пароль». В окне выбора пользователя укажите ваше имя и старый пароль, нажмите кнопку «принять». Укажите новый пароль в строке «Новый пароль» и «подтверждение пароля». Нажмите кнопку «сохранить» и «выйти».

В меню «настройки» есть пункты настроек программы и связи. Вам нет необходимости изменять эти настройки, поэтому, если по этому поводу у вас возникают сомнения, обращайтесь к разработчикам. mailto: 2318@r66.ru

Далее, самое сложное, настройка свойств объектов. С особым вниманием отнеситесь к этой главе, без понимания процессов, которые происходят при настройке объектов, не изменяйте свойства объектов, иначе можете создать ситуацию, при которой система не будет работать! Настройка объектов будет описана для случая, когда ни одного объекта не установлено в системе, нужно полностью настроить все объекты. Настройка свойств объектов производится в окне «Настройка объектов», которое вызывается через меню «Настройка >> Объекты». В левой части находится дерево конфигурации объектов, которое определяет, в каком порядке объекты подключены в системе. Элементы этого дерева можно выделять левой кнопкой мыши. А при помощи правой кнопки мыши можно вызвать всплывающее меню, в котором описаны действия, доступные для модификации дерева. При помощи всплывающего меню можно добавлять и удалять объекты. Слева от элемента дерева, к которому подключены какие-либо объекты есть значок «+», нажав который можно развернуть дочерние объекты данного объекта (при этом «+» превратится в «–», при помощи которого развернутые объекты можно свернуть). В правой части возникают элементы настройки, доступные для объекта, выбранного в левой части. В вершине дерева находится объект «компьютер», обозначенный белым цветом, который не обладает доступными для пользователя свойствами, поэтому если вы выберите объект «компьютер», то в правой части окна не увидите никаких элементов настройки. Зато к объекту «компьютер» при помощи всплывающего меню можно добавить объекты двух типов (контроллер и маршрутизатор). В большинстве случаев на месте диспетчера к компьютеру подключен концентратор, который нужно сконфигурировать. В концентратор установлены платы, которые являются маршрутизаторами системы. Обычно, это одна плата «KN-485». Поэтому, в окне дерева к компьютеру нужно подключить маршрутизатор. Для этого левой кнопкой мыши выбираем в дереве объект «компьютер», вызываем правой кнопкой мыши всплывающее меню, в котором нажатием левой кнопкой мыши выбираем действие «добавить маршрутизатор». При этом в дерево добавляется элемент «новый маршрутизатор», обозначенный синим цветом. Выбрав этот объект (напоминаю, выбор осуществляется левой кнопкой мыши), получаем ряд доступных свойств в правой части окна. Это такие свойства: название объекта, номер объекта, локальный адрес. Название объекта вы можете изменить, изменив строку с названием. Для этого левой кнопкой мыши выделите строку редактирования названия и при помощи клавиатуры измените его (например «плата KN-485 концентратора»). Измените номер объекта и локальный адрес (в случае, если у вас в концентраторе стоит одна плата, номер объекта – 0, а локальный адрес – 1).

Теперь, к этому маршрутизатору можно подключать дочерние объекты (контроллеры и маршрутизаторы), или удалить его. Все эти действия выполняются при помощи всплывающего меню (сначала левой кнопкой выделите объект, а затем правой кнопкой вызывайте всплывающее меню). В большинстве случаев, в вашей системе не будет больше маршрутизаторов. При помощи всплывающего меню добавляем к нашему маршрутизатору контроллер (все также при помощи всплывающего меню). Контроллер обозначается зеленым цветом. Для контроллера доступны следующие свойства (в правой части окна): библиотека объекта, название объекта, номер объекта, локальный адрес и локальный план. Что делать с названием, номером и локальным адресом мы уже знаем (например: название – «ТП 68», номер – 1, локальный адрес – 1). Напомню, что номер объекта и локальный адрес определяются в пункте 4 данного руководства. Неизвестными остаются свойства: библиотека объекта и локальный план. Библиотека объекта – это файл, при помощи которого система знает, как общаться с данным объектом и какими свойствами он обладает. Двойным нажатием мыши на строку редактирования библиотеки объекта вызываем диалоговое окно открытия файла, при помощи которого выбираем нужную библиотеку. (для контроллеров КСИ это файл ksi_001.dll, который находится по месту d:\delphi_p\gorsvet\end). Локальный план, это дополнительный файл для данного контроллера. (Для контроллера КСИ это план переключений, по которому объект будет включаться в координированном управлении. Например, вы можете создать отличающийся от локального плана, зашитого в контроллер, план переключений, для отработки которого, достаточно объект перевести в координированное управление. Например, план без ночного отключения освещения можно назначить для всех контроллеров КСИ в системе, и, когда надо, переводить их в координированное управление.) Нужно помнить, что файл, обозначенный как локальный план, может работать только при включенном компьютере и работающей системе. К контроллеру можно добавить дочерние объекты при помощи все того же всплывающего меню. Контроллер можно удалить, но в этом случае удалятся и все дочерние объекты. Это следует помнить.

После того, как вы определили библиотеку объекта, к объекту добавляются дочерние объекты, определенные для этого типа объекта без дополнительных настроек. Это пакеты параметров, обозначенные красным цветом и связанные параметры, обозначенные темно-желтым цветом. Пакеты параметров – это наборы параметров связанные в группу по определенному критерию. Связанный параметр, это ссылка на параметр другого контроллера с целью использования общих параметров. Например, для контроллера КСИ определен один связанный параметр – освещенность, который должен ссылаться на параметр освещенности контроллера измерения освещенности, что может использоваться для адаптивного управления контроллером КСИ. Этот параметр зарезервирован для использования в будущем, и пока настройке не подлежит. А вот настройка пакета параметров – вещь необходимая. (Вы можете изменить название пакета параметров, но в этом нет необходимости). Для пакета параметров нужно задать интервал опроса. Это то время, через которое будет осуществляться запрос параметров, определенных в этом пакете. Интервал опроса задается в секундах, и должен содержать такое значение, при котором система должна иметь значительное свободное время для отработки тех или иных ситуаций. Подробнее об этом будет описано в следующей главе, посвященной работе библиотеки ksi_001.dll. Пока же следует отметить, что времена опросов для пакетов «состояние объекта», «дополнительные параметры» и «управление объектом» следует задать примерно как количество объектов в системе умноженное на 3 (при количестве объектов = 40, интервалы опросов – 120 секунд). Для пакета параметров «системные параметры» интервал опроса не имеет значения.

Развернув содержимое пакета параметров, можем увидеть дочерние объекты пакета параметров. Это – параметры, связанные в этот пакет. Параметры отображаются желтым цветом. Для параметров определены следующие свойства: константа 1, константа 2 и флажок «писать в базу». Флажок «писать в базу» позволяет определить, будет ли записываться состояние параметра при его изменении в базу данных или нет. Константы 1 и 2 определяют необходимые для вычисления параметра константы. Для большинства параметров эти константы не имеют значения, но для некоторых эти константы важны. (Для параметра «количество несвязей» в пакете параметров «системные параметры» константа 1 определяет количество несвязей с контроллером, прежде чем возникнет ошибка «нет связи». Рекомендуемое значение – 10. Для параметра «потребленная энергия» в пакете «дополнительные параметры» константа 1 определяет коэффициент трансформации для токовых трансформаторов, подключенных к электросчетчику на объекте. Для прямоточных счетчиков должно стоять – 1, другие значения – 10, 20, 30 и т. д.). Подробнее об этом в следующей главе.

Еще хотелось бы сказать о параметрах, которые целесообразно записывать в базу данных, для чего используйте флажок «писать в базу». Советуем записывать в базу следующие параметры: в пакете «состояние объекта» - неисправность, режим управления, состояния выходов фазы A, B, C, в пакете «управление объектом» - все параметры. При отладке системы и для выявления ошибок рекомендуется записывать в базу состояние параметров из пакета «дополнительные параметры» - выход. фаза A, B, C. Крайне не рекомендуется записывать в базу время на объекте из-за частого его изменения.

После того, как все необходимые настройки сделаны, закройте окно «настройка объектов», при этом изменения вступят в силу немедленно.

8. Описание библиотеки ksi_001.dll

Как уже говорилось в предыдущей части описания, посвященной настройке системы, для контроллеров, подключенных в систему, необходимо указывать библиотеку устройства (для каждого типа устройств существует своя библиотека). Для контроллера КСИ на данный момент существует библиотека объекта версии 001, отсюда и название – ksi_001.dll. Контроллер, у которого не определена библиотека объекта (абстрактный контроллер), является простым маршрутизатором. После подключения к абстрактному контроллеру библиотеки объекта, этот контроллер получает дополнительные свойства, состоящие из пакетов параметров, которые, в свою очередь, состоят из параметров, контролируемых системой, а также связанных параметров, являющихся ссылками на параметры других контроллеров. Здесь будет описана работа запросов пакетов параметров и описание параметров.

Итак, первый пакет параметров, называемый «Состояние объекта». Этот пакет состоит из следующих параметров: зимнее время – время на объекте без учета перехода на летнее время (зимой это время совпадает с реальным временем, а летом отличается на один час, если в вашей местности есть переход на летнее время. Подробнее читайте об этом в главе, посвященной времени в контроллере); код ошибки контроллера, который в исключительном случае (в случае потери связи с контроллером) подменяется кодом, формируемым библиотекой, а в других случаях формируется контроллером; состояние управления, которое показывает в централизованном или в локальном управлении находится контроллер; состояния выходов – включены или выключены каждый из трех выходов освещения. Этот пакет запрашивается периодически через интервал времени, указанный для этого пакета при условии освобождения процесса формирования запросов. Это означает, что если в данный момент нет более важного запроса, и наступил момент опросить пакет состояния, то он опрашивается. Пакет состояния формируется также после посылки запроса пакета, называемого «Управление объектом», для подтверждения изменения состояния контроллера. В случае пропадания связи с контроллером, пакет состояния начинает запрашиваться через 5 секунд до тех пор, пока не возникнет сообщение об ошибке связи либо не восстановится связь. В этих случаях пакет состояния запрашивается через установленный интервал.

Второй пакет параметров, называемый «Дополнительные параметры» состоит из замеров напряжений на объекте в девяти точках (по три для каждой фазы) и силы тока по трем фазам, текущей мощности, вычисляемой по параметрам напряжений и токов, а также показаний электросчетчика, установленного на объекте. Этот пакет запрашивается через интервал, указанный для него в качестве «периода опроса». В случае пропадания связи с контроллером, пакет дополнительных параметров начинает запрашиваться через 5 секунд до тех пор, пока не возникнет сообщение об ошибке связи либо не восстановится связь. В этих случаях пакет дополнительных параметров запрашивается через установленный интервал.

Третий пакет параметров называется «Управление объектом». Он состоит из следующих параметров: состояние управления объектом (локальное, координированное, диспетчерское, независимое), управление состояниями выходов контроллера (состояния выходов для централизованного управления). Этот пакет запрашивается при несоответствии состояния контроллера с управляющими командами.

Четвертый пакет, называющийся «системные параметры» содержит в себе параметры, которые нужны для работы библиотеки. Они содержат либо вспомогательные данные, либо временные данные. Запрос этого пакета никогда не формируется.

Кроме пакетов параметров у контроллера КСИ есть связанный параметр, называемый «освещенность». Он может применяться для адаптивного управления объектами (в зависимости от освещенности местности). В версии 001 этот параметр не задействован.

Возникает вопрос, каким образом и в каком порядке формируются запросы для объектов? Запросы формируются следующим образом. Допустим, в системе – 40 объектов. Программа «GORSVET» поочередно перебирает объекты путем опроса их библиотек. Если в данный момент библиотека решает сделать запрос, она его формирует, а ведущая программа выставляет этот запрос концентратору. Существуют приоритеты пакетов параметров. Так, пакет «Управление объектом» имеет наивысший приоритет и формируется по мере необходимости. Если необходимости нет, библиотека проверяет, давно ли осуществлялись запросы пакета состояния и пакета дополнительных параметров? Запрашивается тот пакет, период опроса которого истек и превышение этого времени максимально.

Далее, когда запрос попадает в концентратор, он через соответствующую плату расширения транслируется в линию, которая может являться либо линией связи с контроллером, либо с радиомодемом. Следует учесть, что если концентратор связывается напрямую с контроллером, то ответ он может получить сразу, а задержка ответа через радиоканал составляет около 400 миллисекунд. Более того, если по каким-то причинам ответ не последует, то концентратор будет ожидать его в течение одной секунды. Значит, максимальная задержка опроса одного пакета одного контроллера около одной секунды. Мы говорили о том, что пакетов, которые запрашиваются три разновидности, поэтому максимальное время опроса (при отсутствии связи) для 40 объектов – 120 секунд. Значит, времена опросов для пакетов при настройке системы разумно выбирать около 120 секунд. Реально, когда связь с большинством объектов есть, загруженность системы сильно снижается. Если есть связь со всеми контроллерами, а они все подключены по радиоканалу, то период опроса всех контроллеров будет 40*0.4*2=32 секунды. 40 – количество объектов, 0.4 – задержка радиоканала, 2 – количество разных пакетов. Почему два? Потому что пакет управления возникает только при несоответствии команд и состояния объектов (например, контроллер находится в автономном управлении, а из центра идет команда перевести его в диспетчерское), а такие ситуации возникают крайне редко. В установленном режиме локального управления вообще никогда.

Все эти вычисления служат только одной цели – правильно подобрать времена опросов пакетов параметров для наиболее оптимальной работы системы. Возможно, вам придется поэкспериментировать с этими временами и выбрать наиболее подходящие для себя интервалы. По всем интересующим вас вопросам обращайтесь. mailto: 2318@r66.ru

9. Последняя версия программы «GORSVET».

Вообще говоря, не существует окончательной версии программы «GORSVET». Эта программа развивается. Рассматриваются все замечания по работе системы (в том числе ваши) и вносятся необходимые изменения. Версию программы вы можете посмотреть в меню «о программе». Там вы увидите информацию о разработчиках, версию программы, ссылки на адрес электронной почты разработчиков и на страничку фирмы «Комсигнал», а также ссылку на файл помощи, который вы сейчас читаете. Далее будут описаны различия в версиях, начиная с первой версии программы 1.0.0.0. Следует сказать, что последняя цифра версии меняется для подверсий, изменения в которых незначительны и здесь описаны не будут. Будут описаны изменения для версий, в которых меняется первая, вторая и третья цифра.

Версия 1.0.0.0 была первой. Отличительной особенностью этой программы было то, что для контроллеров указывалось абсолютное мировое время по Гринвичу.

В версии 1.0.1.0 время контроллера считается как местное время без учета перехода на летнее время и обратно. Это было сделано для более простого составления плана переключений. Надо сказать, что переход с версии 1.0.0.0 и подверсий на версию выше требует пересмотра таблицы переключений и переконфигурации контроллеров с учетом этих изменений.

С 18 ноября 2003 г. доступна версия 1.0.2.0. В этой версии оптимизированы процессы перерисовки экрана с целью меньшей его загруженности. Также в главное меню добавлен пункт «Редактор», в который внесен подпункт «план переключений». При помощи этой команды можно вызвать редактор плана переключений наиболее быстро. Добавлено цветовое соответствие объекта на карте. Теперь, в состоянии, когда нет ошибок объекта – зеленым цветом отражается объект, контроллер которого находится в локальном управлении, а синим – если в централизованном.

Если у вас есть какие-то замечания или предложения по работе системы, направляйте их на адрес электронной почты разработчиков. mailto: 2318@r66.ru

10.Полезные советы.

В этой главе будут размещаться полезные советы, которые, на наш взгляд, могли бы облегчить вам жизнь при работе с системой. Таких советов пока не много. Спрашивайте, мы разместим ответы здесь.

Совет 1. Как сделать, чтобы сегодня ночью не было ночного отключения освещения.

Если у вас система сконфигурирована таким образом, что локальные планы всех контроллеров КСИ ссылаются на один файл, то сделать вам это совсем легко. Например, локальные планы ссылаются на файл МойГород.sw. Создайте два плана переключений МойГородСНочным.sw и МойГородБезНочного.sw которые будут отличаться тем, что во втором не будет ночного отключения света, а в первом будет. Это делается при помощи редактора плана переключений. Теперь, откройте в редакторе плана переключений файл МойГородБезНочного.sw и сохраните его как МойГород.sw. После этого переведите все объекты в координированное управление, и все объекты будут работать по плану без ночного переключения. Когда вам надо вернуть все обратно, просто переведите все объекты в автономное управление, если основным режимом работы объектов (как мы рекомендуем) является автономное управление. Если основным режимом работы объектов, несмотря ни на что, вы выбрали координированное управление, то вам надо открыть в редакторе плана переключений файл МойГородСНочным.sw и сохранить его как МойГород.sw. И все. Переводить объекты в локальное управление не надо.

Совет 2. Как сделать, чтобы вечернее освещение включалось раньше.

Вы помните, что мы настоятельно советуем основным режимом работы объектов держать автономное управление. Однако, нет ничего криминального в том, что этим режимом будет координированный режим управления. Поэтому, если у вас именно этот режим, то вам просто надо откорректировать план переключения с учетом ваших пожеланий. Как это сделать, вы уже знаете. Сложнее (но надежнее) тем, у кого основным режимом управления является локальный. Измените план переключений и переведите в координированный режим управления по этому плану. Меняйте прошивки на объектах с учетом изменений и измененные объекты переводите в локальное управление.